$re = '/\.tmp$/im';
$str = 'path/to/file.tmp
tmpfile
tmpdir/file.txt
path/to/UPPERCASE_FILE.TMP
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);