// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<date>(0[1-9]|[12][0-9]|3[01])[-/.](0[1-9]|1[012])[-/.]((19|20)\d{2}))").unwrap();
let string = "this is due on 28-02-2021 at 10:00 am
this is due on 28/02/2021 at 10:00 am
this is due on 28.02.2021 at 10:00 am";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}