$re = '/^\d{1,2}$|^100$/m';
$str = '1
2
3
22
...
99
100
101
102
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);