#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\h.]+(?:(?::\d*){1,3}(?::\w*(?::\w+(?:\.\w+)*)?)?)?$"
Local $sString = "Alphanumerictext1" & @CRLF & _
"Alphanumerictext1:1234" & @CRLF & _
"Alphanumerictext1:1234:12" & @CRLF & _
"Alphanumerictext1:1234::124:aplhnumericText2" & @CRLF & _
"Alphanumerictext1::12" & @CRLF & _
"Alphanumerictext1:1234:12:124:aplhnumericText2:www.stackoverflow.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")