# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<errorCode>([^<>]+)</errorCode>"
test_str = (" <?xml version=\"1.0\" endcoding=UTF-8\"?>\n"
" <n0:szemelyKutyaFuleResponsexmlns:prx=\"urn:sap.comproxy:SWP:/1SAI/TREASE1243804269AE457508F4:753\" mmlns:n0=\"http://csajgeneratorws.tny.interfesz.kok.lo/\">\n"
" <return>\n"
" <tanzakciosAzonosito>46981682-4637-49d2-bd4d-dcfff543742ed</tanzakciosAzonosito>\n"
" <erdmeny>HIBAS</eredmeny>\n"
" <errorCode>TSH08</errorCode>\n"
" <errorMessage>Azonosítószám már hozzá lett rendelve üzleti partnerhez</errorMessage>\n"
" </return>\n"
" </n0:szemelyKutyaFuleResponse>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.