$re = '/(https:\/\/)?(www\.)?(((discord(app)?)?\.com\/invite)|((discord(app)?)?\.gg))\/(?<invite>.+)/m';
$str = 'discord.gg/wwwww
.gg/gay
.com/invite/gay
discord.com/invite/ass
https://www.discord.com/invite/ass';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);