// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\\r\\n\d.\d\d.\d\s+\w\\r\\n").unwrap();
let string = "\"1. Entrepreneurship\\r\\nAus der Praxis\\r\\nAndrea hat Wirtschaftsingenieurwesen studiert und ist nun seit zwei Jahren in der\\r\\nLogistik eines größeren mittelständischen Maschinenbauunternehmens tätig. Jörg ist\\r\\nBetriebswirt mit Schwerpunkt Steuern. Er arbeitet seit Abschluss seines Studiums vor\\r\\ndrei Jahren für eine große Wirtschaftsprüfungsgesellschaft. Mark, ein Wirtschaftsinfor-\\r\\nmatiker, führt seit gut zwei Jahren Beratungsprojekte für eine auf Digitalisierung spezia-\\r\\nlisierte Technologieagentur durch. Nathalie hat vor fünf Jahren das BWL-Studium mit\\r\\nSchwerpunkt Personal abgeschlossen. Sie leitet seit zwei Jahren die Personalentwick-\\r\\nlung eines mittelgroßen Elektronikunternehmens.\\r\\nDie vier lernten sich im berufsbegleitenden MBA-Studium durch eine gemeinsame\\r\\nGruppenarbeit kennen. Ihre Aufgabe bestand darin, eine innovative Gründungsidee zu\\r\\nentwickeln. Bei den Vorbereitungen stellten sie fest, dass sie sich in der Verwendung\\r\\neiniger Begriffe nicht sicher sind. Mal sprechen sie von Unternehmern, mal von Selbst-\\r\\nständigen, manchmal auch von Entrepreneuren oder Existenzgründern. Antworten auf\\r\\ndie Fragen, welche Rollen Entrepreneure einnehmen und warum Entrepreneurship\\r\\nvolkswirtschaftlich so wichtig ist, haben sie auch nicht abrufbereit. Insofern wollen sie\\r\\nzuerst eine Begriffsklärung durchführen.\\r\\nHierfür recherchieren sie die folgenden Aspekte:\\r\\n•Was genau versteht man unter Entrepreneurship?\\r\\n•Lassen sich Unterschiede zwischen Entrepreneuren und Unternehmern finden?\\r\\n•Gibt es verschiedene unternehmerbezogene Entrepreneurship-Theorien?\\r\\n•Welche volkswirtschaftliche Signifikanz wird dem Entrepreneurship zugesprochen?\\r\\n1.11.1 Entrepreneurship und Unternehmer\\r\\nEs gibt keine allgemeingültige Definition für die Begriffe „Entrepreneur“ und „Entrepre-\\r\\nneurship“. In der Literatur finden sich verschiedene Ansätze und Zugänge zum Ver-\\r\\nständnis dessen, was unter einem Entrepreneur verstanden wird. Oft wird der innova-\\r\\ntive Charakter des Vorhabens zugrunde gelegt, manchmal auch von Inhabern kleiner\\r\\nund mittlerer Unternehmen, von selbstständig Tätigen oder von Unternehmensinha-\\r\\nbern (die auch Mitarbeiter beschäftigen) gesprochen. Eine Differenzierung erfolgt zum\\r\\nTeil zwischen Personen, die nur einmal gründen, und solchen, die häufiger Unterneh-\\r\\nmen aufbauen (Parker 2018, S. 6f.). Nachfolgend werden eine typische Begriffsverwen-\\r\\ndung und einige andere Ansätze skizziert.\\r\\n12Lektion 1\\r\\nwww.iubh.de\\r\\n\\r\\n\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}