$re = '/^([A-zñÑáéíóú&;0-9 ]{0,100})$/m';
$str = 'E dit ab le ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);