import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([-+*\\/\\(]?[\\(]?([1-9]{1}[0-9]+)[.]?[0-9]+[\\)]?[\\)]?)([-+*\\/\\(]?[\\(]?[\\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\\)]?[\\)]?)?([-+*\\/\\(]?[\\(]?[\\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\\)]?[\\)]?)?([-+*\\/\\(]?[\\(]?[\\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\\)]?[\\)]?)?([-+*\\/\\(]?[\\(]?[\\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\\)]?[\\)]?)?([-+*\\/\\(]?[\\(]?[\\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\\)]?[\\)]?)?$";
final String string = "690.91+(1.3*(4-7/(3+6.4)))\n"
+ "+(690.91)+1\n"
+ "1+1\n"
+ "+(690.91)+(1.3*(4-7/(3+6.4)))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}