using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([-+*\/\(]?[\(]?([1-9]{1}[0-9]+)[.]?[0-9]+[\)]?[\)]?)([-+*\/\(]?[\(]?[\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\)]?[\)]?)?([-+*\/\(]?[\(]?[\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\)]?[\)]?)?([-+*\/\(]?[\(]?[\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\)]?[\)]?)?([-+*\/\(]?[\(]?[\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\)]?[\)]?)?([-+*\/\(]?[\(]?[\(]?([1-9]{1})([0-9]+)?[.]?([0-9]+)?[\)]?[\)]?)?$";
string input = @"+(690.91+1
690.91)+1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}