$re = '/\b(\w+)\b(.*\b\1\b){3}/m';
$str = 'a a a b b e e e
o o o o p p p y y y
w r r r u u i i o o r
x x o o i i p p z z y y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);