#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.+?(?=administrator)).*((?<=administrator[0-9]).*)"
Local $sString = "/home/clems/ftp.irt-conseil.com/administrator1/ca/index.php" & @CRLF & _
"/home/clems/ftp.irt-conseil.com/administrator2/index.php "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")