const regex = /\bdog\b(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bdog\\b(?!$)', 'gm')
const str = `The quick brown fox jumps over the lazy dog
The dog was lazy`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);