#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ab]{3,}(?<!^.\1.*(.))$"
Local $sString = "aaabbbbababab" & @CRLF & _
"" & @CRLF & _
"aaabbbbababaa" & @CRLF & _
"ababbbbababab" & @CRLF & _
"ababbbbababaa" & @CRLF & _
"abb" & @CRLF & _
"aba" & @CRLF & _
"aab" & @CRLF & _
"aaa" & @CRLF & _
"a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")