package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w`)
var str = `1abc a2c ac3b aob4 ab a56c 7 - ( ) + _ 10
11
abc
AB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}