$re = '/\D/m';
$str = '1abc a2c ac3b aob4 ab a56c 7 - ( ) + _ 10
11
abc
AB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);