$re = '/\$\d/m';
$str = '$1 dolar
$6 reais
$1 euro';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);