package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\([^>]*\))`)
var str = `(1, 'AC', 'Acre'), (2, 'AL', 'Alagoas'), (3, AM, 'Amazonas')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}