$re = '/(1|2)([0-9])|(3)(0|1)|^([0-9]){1}$/';
$str = '33';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);