package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s*//)?(?:\s*Connection\s+)?(.+?)\s*=\s*new\s+DBConnection`)
var str = `Connection variable = new DBConnection
variable = new DBConnection
//
//Connection variable = new DBConnection
//variable = new DBConnection
// Connection variable = new DBConnection
// variable = new DBConnection`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}