const regex = /\d{3}\s+[a-z]\s+\d{2}[a-z]{2}\s+[a-z]{2}\s+[a-z]{6}\s+[a-z]{10}\s+[0-9]{5}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3}\\s+[a-z]\\s+\\d{2}[a-z]{2}\\s+[a-z]{2}\\s+[a-z]{6}\\s+[a-z]{10}\\s+[0-9]{5}', 'g')
const str = `925 s 10th st tacoma washington 98405`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}