re = /^(?=.*\p{Ll})(?=.*\p{Lu})(?=.*\p{Nd})(?=.*[@$!%*?&])[\p{L}\p{Nd}$@!%*?&]{8,}$/m
str = '关键字157aA$89
P455word123!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end