$re = '/^[\w\s]{3}(.*?)$/m';
$str = 'This is a test.
A test this is.
First three letters should be selected.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);