package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-9]|0[0-9]|1[0-9]|2[0-3]):[0-5][0-9]?$`)
var str = `0:0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}