import re
regex = re.compile(r"^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$", flags=re.MULTILINE)
test_str = ("/^(?=.*\\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\\w\\d\\s:])([^\\s]){8,16}$/gm\n"
"_}24I:9t58Tu?m@e\n"
"|YlzEc|1\n"
"#m_4xF%t\"Bu5jeb$\n"
"Password1!\n"
"12345678aA\n"
"^@},^@},^@},\n"
"12345678aA@ \n"
"12345678 aA@\n"
" 12345678aA@\n"
"AbCdEfGhIi\n"
"abcdefgh123\n"
"ABCDEFGH1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")