package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`slug: (.*)\n`)
var str = `slug: asdf asdf
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}