// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]{1}$|10").unwrap();
let string = "0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}