# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!&)(?:\b(?:[a-z]{2,8}\d{0,2})|#[0-9a-f]+);"
test_str = ("I have a huge HTML with several special chars, in the forms or \"�.\n"
"Faulty HEX: #82173333;\n"
"Some of them are wrong, because they lack the initial &.\n\n"
"I would like to search for such wrong spacial chars. I know that I can search all the right special chars by means of the following regex:\n\n"
" \\&(?:[a-z]+|#x?\\d+);\\\n"
"But I'd need a regex useful to search the wrong ones (without the initial &). Can you help me? Thanks in advance\n\n"
"Edit:\n\n"
"As suggested, I post an example. My HTML cointains the following statement:\n\n"
" <![CDATA[<nolink>blablabla blablabla</nolink>]]>nbsp;\n"
"where we have 2 special HTML character:\n"
"divide;\n"
"÷\n"
" \n"
"quot;\n"
"I'm interested in finding the second item, because it is wrong (laking the initial &).\n\n"
"So the output of the requested regex should be: quot;")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.