#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*[/\\]"
Local $sString = "%abc%\xyz\test.exe" & @CRLF & _
"%abc%/xyz/test.exe" & @CRLF & _
"test.exe"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)