using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hsl\(\d{1,3}, +\d{1,2}%, +\d{1,2}%\)";
string input = @"color: hsl(10, 3%, 19%);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}