$re = '/\[(if|elseif|else) ?(.*?)\](((?R)|[^\[\]])*?)(?:.(?=\[else.*?\])|\[\/if\])/s';
$str = ' [if true]
[if true]
[if false]
[else]
[/if]
[elseif false]
[if true]
[/if]
[else]
[/if]
[elseif false]
[/if]
[if false]
[if false]
[else]
[/if]
[else]
[if true]
[/if]
[/if]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);