import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"UID\\s*([^\\n\\r]*))";
final String string = "{\n"
+ " \"Tabelle1\": [\n"
+ " {\n"
+ " \"Nr.\": \"1\",\n"
+ " \"Firma\": \"Alba Reisen/Versicherungen/Darlehen H. Kajtazi\",\n"
+ " \"Rechtsform\": \"EIU\",\n"
+ " \"Sitz\": \"Rapperswil-Jona\",\n"
+ " \"Kanton\": \"SG\",\n"
+ " \"UID\": \"CHE‑101.868.757\"\n"
+ " },\n"
+ " {\n"
+ " \"Nr.\": \"2\",\n"
+ " \"Firma\": \"Alybaba - Schischa Laden, Aly\",\n"
+ " \"Rechtsform\": \"EIU\",\n"
+ " \"Sitz\": \"Wil (SG)\",\n"
+ " \"Kanton\": \"SG\",\n"
+ " \"UID\": \"CHE‑102.012.121\"\n"
+ " },\n"
+ " {\n"
+ " \"Nr.\": \"3\",\n"
+ " \"Firma\": \"Bluamawerkstatt zur Linde Marianne Bislin-Lieberherr\",\n"
+ " \"Rechtsform\": \"EIU\",\n"
+ " \"Sitz\": \"Pfäfers\",\n"
+ " \"Kanton\": \"SG\",\n"
+ " \"UID\": \"CHE‑217.602.289\"\n"
+ " },\n"
+ " ]\n"
+ "}\n";
final String subst = "$1,\"X\":\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}