import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)^(?<message>.*?)\\s*:[\\r\\n\\s]+ProgID\\s+:\\s+(?<ProgID>[^\\r\\n]+)";
final String string = "Outlook a désactivé le ou les compléments suivants :\n"
+ "ProgID : ColleagueImport.ColleagueImportAddin\n"
+ "GUID : {EFEF7FDB-0CED-4FB6-B3BB-3C50D39F4120}\n"
+ "Nom : Microsoft SharePoint Server Colleague Import Add-in";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}