$re = '/\'(?P<ts>\d{4}-\d\d-\d\dT\d\d:\d\d:\d\dZ).*?db=(?P<db>\S*).*?user=(?P<user>\S*).*?LOG:\s+(?P<query>.*?);$/m';
$str = '\'2022-05-08T04:18:43Z UTC [ db=dev user=test pid=1073922359 userid=100 xid=2063 ]\' LOG: alter table my_table alter column string type varchar(16);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);