$re = '/,[^,]+_sys$/m';
$str = 'abc,def,ghi,jkl_sys';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);