#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[((?P<serial>\d{14}){0,1}[\.\w]*-(?P<pccode>[\dA-Z]{8}))\] +"
Local $sString = "2017-06-15 06:05:25*6 --- ERROR "?? ?.?.?. ??? ????? ????????"--- FieldName:AFM, OldValue:, NewValue:125433937 " & @CRLF & _
"2017-06-15 06:05:25*6 [01102409405015-02CB3A00] setData ---- ESoftOneError: ?? ?.?.?. ??? ????? ???????? ***** " & @CRLF & _
"2017-06-15 06:05:25*6 [01102409405015-02CB3A00] getData ---- EDatabaseError: [42S22] [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Invalid column name 'false'. (207)" & @CRLF & _
"[42S22] [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Invalid column name 'false'. (207)" & @CRLF & _
"[42S22] [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Invalid column name 'false'. (207)" & @CRLF & _
"2017-06-15 06:05:46*3 [01100279451010-0D6626F0] calculate ---- Time: 4922 ms QCount: 29 QTime: 4624 DataIn: 1990 DataOut: 2576 [37 Trs - 224 MB - 18 %]" & @CRLF & _
"2017-06-15 06:05:51*3 [01100279451010-0D6626F0] setData ---- Time: 3437 ms QCount: 62 QTime: 265 DataIn: 1054 DataOut: 30" & @CRLF & _
"2017-06-15 06:06:14*5 [01102396363715-0839E1A0] Report (customer) ---- Time: 719 ms QCount: 1 QTime: 703 [176 Trs - 161 MB - 11 %]" & @CRLF & _
"2017-06-15 09:35:00*1 [01102342340813-86ED1F51] ******EXCEPTION ProcessPacket disp_ExecuteSQL EDatabaseError: [42000] [Microsoft][SQL Server Native Client 11.0][SQL Server]Incorrect syntax near 'SAMSUNG'. (102)" & @CRLF & _
"[42000] [Microsoft][SQL Server Native Client 11.0][SQL Server]The identifier that starts with '</productDesc>" & @CRLF & _
" <svcLevel>EDX0W</svcLevel>" & @CRLF & _
" <svcLevelDesc>Express ; Customer requested day service</svcLevelDesc>" & @CRLF & _
" <' is too long. Maximum length is 128. (103)" & @CRLF & _
"2017-06-14 08:42:49*2 [01102455824916-C29C87D0] ******EXCEPTION ProcessPacket disp_GetSQLResults EDatabaseError: [42S22] [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Invalid column name 'FIDNOC'. (207) [UPDATE ML SET ML.FINALDATE = CONVERT(VARCHAR,DATEADD(DD,M.CCCLOTDURATION,FD.TRNDATE),103) FROM FINDOC AS FD INNER JOIN MTRLINES AS FDL ON FDL.FINDOC = FD.FINDOC INNER JOIN MTRL AS M ON M.MTRL = FDL.MTRL AND M.CCCLOTDURATION IS NOT NULL INNER JOIN MTRLOT AS ML ON ML.MTRL = M.MTRL AND ML.MT] [13100 Trs - 464 MB - 5 %]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")