#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[\d\n].*\n"
Local $sString = "1" & @CRLF & _
"00:00:01.876 --> 00:00:02.709" & @CRLF & _
"<v Instructor>We can go back now</v>" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:00:02.709 --> 00:00:05.042" & @CRLF & _
"to our web server checklist." & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:00:06.410 --> 00:00:08.722" & @CRLF & _
"We've already seen better ways to organise our code" & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:00:08.722 --> 00:00:11.545" & @CRLF & _
"into reusable pieces with modules," & @CRLF & _
"" & @CRLF & _
"5" & @CRLF & _
"00:00:11.545 --> 00:00:13.315" & @CRLF & _
"we've seen ways to deal with files," & @CRLF & _
"" & @CRLF & _
"6" & @CRLF & _
"00:00:13.315 --> 00:00:15.940" & @CRLF & _
"both synchronous and asynchronous," & @CRLF & _
"" & @CRLF & _
"7" & @CRLF & _
"00:00:15.940 --> 00:00:16.773" & @CRLF & _
"and buffers," & @CRLF & _
"" & @CRLF & _
"8" & @CRLF & _
"00:00:16.773 --> 00:00:18.325" & @CRLF & _
"both the built-in Node one" & @CRLF & _
"" & @CRLF & _
"9" & @CRLF & _
"00:00:18.325 --> 00:00:20.380" & @CRLF & _
"and the ES6 buffers," & @CRLF & _
"" & @CRLF & _
"10" & @CRLF & _
"00:00:20.380 --> 00:00:22.485" & @CRLF & _
"and we've seen a way to deal with work"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)