package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?\n){6}`)
var str = `a
b
c
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}