$re = '/([^\s]+\.\.\.)$|\.\.\.$/m';
$str = 'welcome to this beautiful home
welcome to this beautiful h...
welcome to this beautiful ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);