re = /^[a-zA-Z]([a-zA-Z0-9]|(_(?!_)))+[a-zA-Z0-9]$/m
str = 'as23142
as231 qwdcasd
asdc_sdcsad
asd_
asd__scsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end