const regex = /\bмонито\w{3,}\b/ui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bмонито\\w{3,}\\b', 'ui')
const str = `мой монитор умолк`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}