$re = '/[^[\]]+(?=])/m';
$str = ' [[00], [01], [02], [03]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);