$re = '/(?>https|http|ftp?:\/\/)?[^\s\/$.?#*][^\s\[\],\\\\|]*/m';
$str = 'www.stackoverflow
stackoverflow.com
http://www.stackoverflow.com
https://www.stackoverflow.co
ftp://fdffd.com
someone@stackoverflow.com
foo.bar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);