#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\W([A-Za-z]{8}\d{2})\W"
Local $sString = "1:nlcbjduy14 <- I want regex to find this one " & @CRLF & _
"2:Peoples123 <- I don't want regex to find this one, as it has 3 digits." & @CRLF & _
"3:sqourzyr17 <- I want regex to find this one" & @CRLF & _
"4:rdmaszgr94 <- I want regex to find this one" & @CRLF & _
"5:tnwiudic22 <- I want regex to find this one" & @CRLF & _
"6:zfcxmkrs21 <- I want regex to find this one" & @CRLF & _
"7:xrwhsgno55 <- I want regex to find this one" & @CRLF & _
"8:modtwtrr06 <- I want regex to find this one" & @CRLF & _
"9:People123 <- I don't want regex to find this one, as it is isn't 10 chars long and it consists of 3 digits." & @CRLF & _
"10:aetmyqqh52 <- I want regex to find this one" & @CRLF & _
"11:Howtocodelikeapro12 <- I don't want regex to find this one, as it is isn't 10 chars long" & @CRLF & _
"12:netphvib58 <- I want regex to find this one" & @CRLF & _
"13:uwyiqhoj29 <- I want regex to find this one" & @CRLF & _
"14:RegexJustiIsntDoingItForMe" & @CRLF & _
"15:qyeiaecj27 <- I want regex to find this one" & @CRLF & _
"16:buttercake <- I don't want regex to find this one, as it doesn't end with 2 digits." & @CRLF & _
"17:bcyiyjdm23 <- I want regex to find this one" & @CRLF & _
"18:Differings <- I don't want regex to find this one, as it doesn't end with 2 digits."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")