re = /^(?=.*\d[^\d\n]+\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[-@#$&*+])[-@#$&*+\dA-Za-z]{8,}$/m
str = 'Aa@22abc
Aa@2f2ab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end