package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\W_](?:.*[^\W_])?`)
var str = `!@#$abc-123-4;5.def)(*&^;
_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}