$re = '/[^\W_](?:[\s\S]*[^\W_])?/m';
$str = '!@#$abc-123-4;5.def)(*&^;
_
asdf
!"§$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);