import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\x1B\\[(?:[0-9]{1,3}(?:;[0-9]{1,3})?)?[mGK]";
final String string = "Summary [0m\n\n"
+ "Accounts:\n"
+ "Name Account ID Title\n"
+ "----------------------------------------------- ------------ -----------------------------------------------\n"
+ "[32maccount-accountType-gamma[0m [38;2;128;128;128m123456789012[0m account-accountType-gamma\n"
+ "[32maccount-accountType-e2e-gamma[0m [38;2;128;128;128m123456789012[0m account-accountType-e2e-gamma\n"
+ "Summary [0m\n\n"
+ "Accounts:\n"
+ "Name Account ID Title\n"
+ "---------------------------------------------- ------------ ----------------------------------------------\n"
+ "[32maccount-accountType-e2e-prod[0m [38;2;128;128;128m123456789012[0m account-accountType-e2e-prod\n"
+ "[32maccount-accountType-prod[0m [38;2;128;128;128m123456789012[0m account-accountType-prod";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}