re = /\b(\w+)(\s+\1)+\b/mi
str = 'Goodbye bye bye world world world
Sam went went to to to his business
Reya is is the the best player in eye eye game
in inthe
Hello hello Ab aB'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end