# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([ ]{6})(- )((?!name)\w+[:](?:[ ]*(?=\n\1[ ]{4}\S)|[ ]*\S.+))((?:\n\1[ ]{2}.+)*?)(?:\n(\1[ ]{2})(name[ ]*[:])((?:[ ]*(?![>|])\S.+\b)|(?:(?:[ ]*[>|])?\n\5[ ]+.+)*))[ ]*$"
test_str = ("// YAML Textmate grammar name property hoister\n"
"// Moves a later `name` key value pair in multi value block definition to the \n"
"// top of its \n"
"//\n"
"// # Notes\n"
"// - Indent size is assumed to be 2.\n"
"// - Indent level of names being hoisted is controlled by capture group $1,\n"
"// which is later referenced by $5, the indent level of all other properties\n"
"// - Other properties can be hoisted by replacing the two instances of `name`\n"
"// in the pattern. A couple inputs for simple nested, folded, and literal values \n"
"// (immediately after these notes) seem to work.\n"
"// - Syntax level comments in captures will probably need to be rearranged after \n"
"// applying this, and worst case (especially comments lower indents) break matching\n\n"
" - match: '\\s*(\\,)\\s*'\n"
" name:\n"
" 'Testing': Regex101.Debug.Nested.Name\n"
" - match: '\\s*(\\,)\\s*'\n"
" name:\n"
" 'Testing': Regex101.Debug.Nested.Name.TrailingWhitespace \n"
" - match: '\\s*(\\,)\\s*'\n"
" # Comment\n"
" name:\n"
" 'Testing': Regex101.Debug.Nested.Name.TrailingWhitespace \n"
" - match: '\\s*(\\,)\\s*'\n"
" name: >\n"
" Wow this is a long name?\n"
" kind of sus\n"
" - match: '\\s*(\\,)\\s*'\n"
" name: |\n"
" sus2\n"
" - name: meta.selector.stylus\n"
" match: '\\s*(\\,)\\s*'\n"
" - match: \\*\n"
" name: meta.selector.stylus \n"
" - match: '\\s*(\\&)([a-zA-Z0-9_-]+)\\s*'\n"
" captures:\n"
" '2':\n"
" name: entity.other.attribute-name.parent-selector-suffix.stylus\n"
" name: meta.selector.stylus\n"
" - match: \\s*(\\&)\\s*\n"
" name: meta.selector.stylus\n"
" - captures:\n"
" '1':\n"
" name: punctuation.definition.entity.css\n"
" match: '(\\.)[a-zA-Z0-9_-]+'\n"
" name: entity.other.attribute-name.class.css\n"
" - captures:\n"
" '1':\n"
" name: punctuation.definition.entity.css\n"
" match: '(#)[a-zA-Z][a-zA-Z0-9_-]*'\n"
" name: entity.other.attribute-name.id.css\n"
" - captures:\n"
" '1':\n"
" name: punctuation.definition.entity.css\n"
" match: >-\n"
" (:+)(after|before|content|first-letter|first-line|host|(-(moz|webkit|ms)-)?selection)\\b\n"
" name: entity.other.attribute-name.pseudo-element.css\n"
" - captures:\n"
" '1':\n"
" name: punctuation.definition.entity.css\n"
" match: >-\n"
" (:)((first|last)-child|(first|last|only)-of-type|empty|root|target|first|left|right)\\b\n"
" name: entity.other.attribute-name.pseudo-class.css\n"
" - captures:\n"
" '1':\n"
" name: punctuation.definition.entity.css\n"
" match: >-\n"
" (:)(checked|enabled|default|disabled|indeterminate|invalid|optional|required|valid)\\b\n"
" name: entity.other.attribute-name.pseudo-class.ui-state.css\n"
" - begin: '((:)not)(\\()'\n"
" beginCaptures:\n"
" '1':\n"
" name: entity.other.attribute-name.pseudo-class.css\n"
" '2':\n"
" name: punctuation.definition.entity.css\n"
" '3':\n"
" name: punctuation.section.function.css\n"
" end: \\)\n"
" endCaptures:\n"
" '0':\n"
" name: punctuation.section.function.css\n"
" patterns:\n"
" - include: '#selector'\n"
" - captures:\n"
" '1':\n"
" name: entity.other.attribute-name.pseudo-class.css\n"
" '2':\n"
" name: punctuation.definition.entity.css\n"
" '3':\n"
" name: punctuation.section.function.css\n"
" '4':\n"
" name: constant.numeric.css\n"
" '5':\n"
" name: punctuation.section.function.css\n"
" match: >-\n"
" ((:)nth-(?:(?:last-)?child|(?:last-)?of-type))(\\()(\\-?(?:\\d+n?|n)(?:\\+\\d+)?|even|odd)(\\))\n"
" - match: '((:)dir)\\s*(?:(\\()(ltr|rtl)?(\\)))?'\n"
" captures:\n"
" '1':\n"
" name: entity.other.attribute-name.pseudo-class.css\n"
" '2':\n"
" name: puncutation.definition.entity.css\n"
" '3':\n"
" name: punctuation.section.function.css\n"
" '4':\n"
" name: constant.language.css\n"
" '5':\n"
" name: punctuation.section.function.css\n"
" - match: '((:)lang)\\s*(?:(\\()(\\w+(-\\w+)?)?(\\)))?'\n"
" captures:\n"
" '1':\n"
" name: entity.other.attribute-name.pseudo-class.css\n"
" '2':\n"
" name: puncutation.definition.entity.css\n"
" '3':\n"
" name: punctuation.section.function.css\n"
" '4':\n"
" name: constant.language.css\n"
" '6':\n"
" name: punctuation.section.function.css\n"
" - captures:\n"
" '1':\n"
" name: punctuation.definition.entity.css\n"
" match: '(:)(active|hover|link|visited|focus)\\b'\n"
" name: entity.other.attribute-name.pseudo-class.css\n"
" - captures:\n"
" '1':\n"
" name: punctuation.definition.entity.css\n"
" match: '(::)(shadow)\\b'\n"
" name: entity.other.attribute-name.pseudo-class.css")
subst = "$1$2$6$7\\n$5$3$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.